summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2021-02-25 12:46:42 +1100
committerLeo Famulari <leo@famulari.name>2021-04-09 16:09:24 -0400
commit944640f3ee07f88a08d8318e72df5fb2bd6328a2 (patch)
treeba7f97be9ee2143625cb7961ac7a7dd8c8bd5644 /gnu
parent586f017d9800a23c71b347c74aee5017a168b35b (diff)
downloadguix-patches-944640f3ee07f88a08d8318e72df5fb2bd6328a2.tar
guix-patches-944640f3ee07f88a08d8318e72df5fb2bd6328a2.tar.gz
gnu: Add python-ifaddr.
* gnu/packages/python-xyz.scm (python-ifaddr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e72d124e28..c52c70ec89 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -43,7 +43,7 @@
;;; Copyright © 2017, 2018, 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
-;;; Copyright © 2017, 2019 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2017, 2019, 2021 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2018 Ethan R. Jones <ethanrjones97@gmail.com
;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
@@ -20988,6 +20988,31 @@ by Igor Pavlov.")
(define-public python2-pylzma
(package-with-python2 python-pylzma))
+(define-public python-ifaddr
+ (package
+ (name "python-ifaddr")
+ (version "0.1.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ifaddr" version))
+ (sha256
+ (base32
+ "150sxdlicwrphmhnv03ykxplyd2jdrxz0mikgnivavgilrn8m7hz"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _ (invoke "nosetests"))))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/pydron/ifaddr")
+ (synopsis "Network interface and IP address enumeration library")
+ (description "This package provides a network interface and IP address
+enumeration library in Python.")
+ (license license:expat)))
+
(define-public python2-zeroconf
(package
(name "python2-zeroconf")