summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2021-12-31 20:14:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-31 20:20:37 +0100
commit4f35f15539be4c0970253aa2cae270879b50362e (patch)
tree58202b3042d2c1dad7a1df84dfbfd9d5729777cb /gnu
parent3fb96020999cdc5f030bd86c72b9dafb7ed7e255 (diff)
downloadguix-patches-4f35f15539be4c0970253aa2cae270879b50362e.tar
guix-patches-4f35f15539be4c0970253aa2cae270879b50362e.tar.gz
gnu: Add r-mlr3pipelines.
* gnu/packages/cran.scm (r-mlr3pipelines): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f03d0ae8a8..6dec698c54 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -28286,6 +28286,37 @@ helper functions for functional programming, for printing, to work with
package also supersedes the package @code{BBmisc}.")
(license license:lgpl3)))
+(define-public r-mlr3pipelines
+ (package
+ (name "r-mlr3pipelines")
+ (version "0.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "mlr3pipelines" version))
+ (sha256
+ (base32
+ "1x738b312mcvb0dif88sv4nlh3y6i47q0wagc5ggyh1hnqjiz71y"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-backports
+ r-checkmate
+ r-data-table
+ r-digest
+ r-lgr
+ r-mlr3
+ r-mlr3misc
+ r-paradox
+ r-r6
+ r-withr))
+ (home-page "https://mlr3pipelines.mlr-org.com/")
+ (synopsis "Preprocessing Operators and Pipelines for @code{mlr3}")
+ (description "@code{mlr3pipelines} enriches @code{mlr3} with a diverse
+set of pipelining operators (PipeOps) that can be composed into graphs.
+Operations exist for data preprocessing, model fitting, and ensemble learning.
+Graphs can themselves be treated as @code{mlr3} Learners and can therefore be
+resampled, benchmarked, and tuned.")
+ (license license:lgpl3)))
+
(define-public r-paradox
(package
(name "r-paradox")