summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2021-10-07 18:08:01 +0200
committerClément Lassieur <clement@lassieur.org>2021-10-07 18:29:14 +0200
commit34baab7a7b66610b592a1e5703470c75a1e06c7f (patch)
tree106898096024fba75ed6bc16603b297e5be71673 /gnu
parentf7f036e7c369515ad678cc08dd5bc9e254804d38 (diff)
downloadguix-patches-34baab7a7b66610b592a1e5703470c75a1e06c7f.tar
guix-patches-34baab7a7b66610b592a1e5703470c75a1e06c7f.tar.gz
gnu: Add emacs-global-tags.
* gnu/packages/emacs-xyz.scm (emacs-global-tags): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 387acbe58a..1c37adfb47 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29560,3 +29560,29 @@ current region or entire buffer.")
It includes syntax highlighting, automatic indentation, and imenu integration.
Unlike Emacs' generic ASM mode, it understands NASM-specific syntax.")
(license license:unlicense)))
+
+(define-public emacs-global-tags
+ (let ((commit "06db25d91cc8bfb5e24e02adc04de1226c7e742d")
+ (revision "0"))
+ (package
+ (name "emacs-global-tags")
+ (version (git-version "0.7" revision commit))
+ (home-page "https://git.launchpad.net/global-tags.el/")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1q30cbqq0h1gfwlcbnx9s930li7w7a0y8sx2ivbvvyyc2j5gsk4j"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-async" ,emacs-async)
+ ("ht" ,emacs-ht)))
+ (synopsis "Testeable Emacs Lisp API that wraps around GNU Global")
+ (description "This package provides a testeable Emacs Lisp API that
+wraps GNU Global calls and integration to editor using this API with
+project.el and xref.el.")
+ (license license:gpl3+))))