summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-02 15:12:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:29 +0200
commitbda61541d530bc9242b8887fc98264e3ecdcee00 (patch)
tree179404d624662b4389573d6f7d9c1a18839770ee /gnu
parent137f9cbc8880d9e54a0055fc7c6fe0c58a2124ea (diff)
downloadguix-patches-bda61541d530bc9242b8887fc98264e3ecdcee00.tar
guix-patches-bda61541d530bc9242b8887fc98264e3ecdcee00.tar.gz
gnu: Add texlive-latex-anysize.
* gnu/packages/tex.scm (texlive-latex-anysize): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index aa4f739c55..2a7461c13e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1691,6 +1691,39 @@ other programs in the distribution offer online interactive use (with
hypertext linkages in some cases).")
(license license:gpl3+)))
+(define-public texlive-latex-anysize
+ (package
+ (name "texlive-latex-anysize")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/anysize"))
+ (revision %texlive-revision)))
+ (sha256
+ (base32
+ "19khwqjlvznc955sijhww3c4zbb0053rvzwv9nz738qknq7y18vb"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/anysize")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/anysize")
+ (synopsis "Simple package to set up document margins")
+ (description
+ "This is a simple package to set up document margins. This package is
+considered obsolete; alternatives are the @code{typearea} package from the
+@code{koma-script} bundle, or the @code{geometry} package.")
+ (license license:public-domain)))
+
(define texlive-texmf
(package
(name "texlive-texmf")