summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-03 10:39:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-03 10:43:08 +0200
commiteb632a28db27ea4a46301229ca330c56267ffe0a (patch)
tree59c47e526c290c789efe8b1e46ece93a01e33813 /gnu
parent10f554700c417b84c22c56fdd007567a52c45d75 (diff)
downloadguix-patches-eb632a28db27ea4a46301229ca330c56267ffe0a.tar
guix-patches-eb632a28db27ea4a46301229ca330c56267ffe0a.tar.gz
gnu: Add r-exactextractr.
* gnu/packages/cran.scm (r-exactextractr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 25a6f71ca4..8bc6acdd02 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -29958,3 +29958,31 @@ applications. The OpenCPU server runs either as a single-user development
server within the interactive R session, or as a multi-user stack based on
Apache2.")
(license license:asl2.0)))
+
+(define-public r-exactextractr
+ (package
+ (name "r-exactextractr")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "exactextractr" version))
+ (sha256
+ (base32
+ "1xnccadbj03h7m81ix5qn0hx918xc9hbxnzgv5lr3hf8b26i9wni"))))
+ (properties `((upstream-name . "exactextractr")))
+ (build-system r-build-system)
+ (inputs `(("geos" ,geos)))
+ (propagated-inputs
+ `(("r-raster" ,r-raster)
+ ("r-rcpp" ,r-rcpp)
+ ("r-sf" ,r-sf)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://isciences.gitlab.io/exactextractr/")
+ (synopsis "Fast extraction from raster datasets using polygons")
+ (description
+ "This package provides a replacement for the @code{extract} function from
+the @code{raster} package that is suitable for extracting raster values using
+@code{sf} polygons.")
+ (license license:asl2.0)))