summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2020-11-23 23:34:46 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-24 09:17:05 +0100
commit9147833ce8067fa4bee6d91aa928f6610a434044 (patch)
tree646dd45efe44a64aee968b734276d59c52212498 /gnu
parent83324d3ad975160e224ff3c0c65cb833ddf3f0c5 (diff)
downloadguix-patches-9147833ce8067fa4bee6d91aa928f6610a434044.tar
guix-patches-9147833ce8067fa4bee6d91aa928f6610a434044.tar.gz
gnu: Add emacs-gn-mode.
* gnu/packages/emacs-xyz.scm (emacs-gn-mode): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9136e4ef2f..fc4a7a4986 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -85,6 +85,7 @@
;;; Copyright © 2020 Adam Kandur <rndd@tuta.io>
;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
;;; Copyright © 2020 Noah Landis <noahlandis@posteo.net>
+;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -10602,6 +10603,28 @@ provides functions to convert hash tables from and to alists and plists.")
you to deal with multiple log levels.")
(license license:gpl3+)))
+(define-public emacs-gn-mode
+ (package
+ (name "emacs-gn-mode")
+ (version "0.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lashtear/gn-mode")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dz5kgzbgsssr38z2kg6m915cvfys42ag1k42bsra3la2pixywfx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/lashtear/gn-mode")
+ (synopsis "Emacs major mode for editing GN (ninja generator) config files")
+ (description
+ "GN mode is a major mode for editing @acronym{GN,Ninja Generator} config
+files in Emacs. Files of this type (e.g., @file{BUILD.gn} or @file{*.gni})
+are common in Chromium-derived projects.")
+ (license license:bsd-3)))
+
(define-public emacs-gntp
(package
(name "emacs-gntp")