summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-05-07 12:43:31 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-05-07 12:43:31 +0200
commitbdd30bf00b04b8d236140f865f23e44ea2a28b86 (patch)
treee09c4dc23dc583f839692c9f42f5ab8b997ea260 /gnu
parent91936f153a6d1026350a1f58bf93f54d2ee3e1dc (diff)
downloadguix-patches-bdd30bf00b04b8d236140f865f23e44ea2a28b86.tar
guix-patches-bdd30bf00b04b8d236140f865f23e44ea2a28b86.tar.gz
gnu: Add sbcl-find-port, cl-find-port, and ecl-find-port.
* gnu/packages/lisp.scm (sbcl-find-port, cl-find-port, ecl-find-port): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 4eeb801c70..167c4433b1 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -5288,3 +5288,36 @@ various levels and mix text with expressions.")
(define-public ecl-log4cl
(sbcl-package->ecl-package sbcl-log4cl))
+
+(define-public sbcl-find-port
+ (let ((commit "00c96a25af93a0f8681d34ec548861f2d7485478")
+ (revision "1"))
+ (package
+ (name "sbcl-find-port")
+ (build-system asdf-build-system/sbcl)
+ (version "0.1")
+ (home-page "https://github.com/eudoxia0/find-port")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0d6dzbb45jh0rx90wgs6v020k2xa87mvzas3mvfzvivjvqqlpryq"))))
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (inputs
+ `(("sbcl-usocket" ,sbcl-usocket)))
+ (synopsis "Find open ports programmatically in Common Lisp")
+ (description "This is a small Common Lisp library that finds an open
+port within a range.")
+ (license license:expat))))
+
+(define-public cl-find-port
+ (sbcl-package->cl-source-package sbcl-find-port))
+
+(define-public ecl-find-port
+ (sbcl-package->ecl-package sbcl-find-port))