summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-19 10:33:37 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:55 +0200
commit01c2b09136b971b48796c607261da745292d15cd (patch)
treea6ae065eaa8fc9250efaab3732c2114c34ddd7b0 /gnu
parentb74dd0237cd641b6dd1823e9c8992a60d021f2c9 (diff)
downloadguix-patches-01c2b09136b971b48796c607261da745292d15cd.tar
guix-patches-01c2b09136b971b48796c607261da745292d15cd.tar.gz
gnu: Add rust-new-debug-unreachable-1.0.
* gnu/packages/crates-io.scm (rust-new-debug-unreachable-1.0): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3614a9f449..8d19cc6db2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5427,6 +5427,30 @@ pairs in insertion order.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-new-debug-unreachable-1.0
+ (package
+ (name "rust-new-debug-unreachable")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "new_debug_unreachable" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0c1br326qa0rrzxrn2rd5ah7xaprig2i9r4rwsx06vnvc1f003zl"))))
+ (build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
+ (home-page
+ "https://github.com/mbrubeck/rust-debug-unreachable")
+ (synopsis
+ "Panic in debug, @code{intrinsics::unreachable()} in release")
+ (description
+ "Panic in debug, @code{intrinsics::unreachable() }in
+release (fork of debug_unreachable)")
+ (license license:expat)))
+
(define-public rust-nix-0.15
(package
(name "rust-nix")