summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-10-05 21:49:24 -0500
committerEric Bavier <bavier@member.fsf.org>2015-10-29 17:30:18 -0500
commite17d513381296b7dd93e09b52529d670ae1c5c9d (patch)
tree37b262e0e110680f155925c09704f496fb3c901d /gnu
parentc6e030b2e3965222e6bb27306311aaec9c7ae93c (diff)
downloadguix-patches-e17d513381296b7dd93e09b52529d670ae1c5c9d.tar
guix-patches-e17d513381296b7dd93e09b52529d670ae1c5c9d.tar.gz
gnu: ghc: Add GHC_PACKAGE_PATH native search path.
Benefits include: 'guix environment' more useful for ghc libraries, more useful 'guix package --search-paths' for installed ghc libraries, cleaner package recipes: no longer need to propagate runtime package dependencies. * guix/build/haskell-build-system.scm (configure): Unset GHC_PACKAGE_PATH around cabal configure. (make-ghc-package-database): Use pattern directory search. (register): Install complete package database for the current package. * gnu/packages/haskell.scm (ghc): Add native-search-paths field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 34cad87b4b..652409b963 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -234,6 +234,12 @@
(string-append ghc-bootstrap-path "/" ,name "-" ,version)
(zero? (system* "make" "install"))))
%standard-phases)))))))
+ (native-search-paths (list (search-path-specification
+ (variable "GHC_PACKAGE_PATH")
+ (files (list
+ (string-append "lib/ghc-" version)))
+ (file-pattern ".*\\.conf\\.d$")
+ (file-type 'directory))))
(home-page "https://www.haskell.org/ghc")
(synopsis "The Glasgow Haskell Compiler")
(description