summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 10:26:51 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:15 -0500
commitd443a52a5648a3a35e85c717ac8e8b72b76ea69a (patch)
tree4f3bf9a253a6dbb9d160cd63692243168b2038f7 /gnu
parent4a35e3c34e755de91d6c5f2f0d610530dd935349 (diff)
downloadguix-patches-d443a52a5648a3a35e85c717ac8e8b72b76ea69a.tar
guix-patches-d443a52a5648a3a35e85c717ac8e8b72b76ea69a.tar.gz
gnu: ghc-fast-logger: Update to 2.4.17.
* gnu/packages/haskell-xyz.scm (ghc-fast-logger): Update to 2.4.17. [inputs]: Add 'ghc-unix-compat'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 01b532cdd7..9518ca3cb8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3333,7 +3333,7 @@ when used with GHC versions which already provide the
(define-public ghc-fast-logger
(package
(name "ghc-fast-logger")
- (version "2.4.11")
+ (version "2.4.17")
(source
(origin
(method url-fetch)
@@ -3343,12 +3343,13 @@ when used with GHC versions which already provide the
".tar.gz"))
(sha256
(base32
- "1ad2vq4nifdxshqk9yrmghqizhkgybfz134kpr6padglb2mxxrdv"))))
+ "02mxb1ckvx1s2r2m11l5i2l5rdl7232p0f61af6773haykjp0qxk"))))
(build-system haskell-build-system)
(inputs
`(("ghc-auto-update" ,ghc-auto-update)
("ghc-easy-file" ,ghc-easy-file)
- ("ghc-unix-time" ,ghc-unix-time)))
+ ("ghc-unix-time" ,ghc-unix-time)
+ ("ghc-unix-compat" ,ghc-unix-compat)))
(native-inputs
`(("hspec-discover" ,hspec-discover)
("ghc-hspec" ,ghc-hspec)))