summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 10:10:01 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:11 -0500
commit5d1339427a688234a5d05b11e8dfeccf822c8193 (patch)
tree0faf4a90fb3b928c7e00e719acaccea545e9324b /gnu
parent79d9326f621476e43a80332de801c08592af64d8 (diff)
downloadguix-patches-5d1339427a688234a5d05b11e8dfeccf822c8193.tar
guix-patches-5d1339427a688234a5d05b11e8dfeccf822c8193.tar.gz
gnu: ghc-psqueues: Update to 0.2.7.2.
* gnu/packages/haskell-xyz.scm (ghc-psqueues): Update to 0.2.7.2. [native-inputs]: Remove 'ghc-test-framework', 'ghc-test-framework-hunit', and 'ghc-test-framework-quickcheck2'; add 'ghc-tasty', 'ghc-tasty-hunit', and 'ghc-tasty-quickcheck'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7f0b3b3776..aa15fd5b59 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -7961,7 +7961,7 @@ API.")
(define-public ghc-psqueues
(package
(name "ghc-psqueues")
- (version "0.2.7.0")
+ (version "0.2.7.2")
(source
(origin
(method url-fetch)
@@ -7970,7 +7970,7 @@ API.")
"psqueues-" version ".tar.gz"))
(sha256
(base32
- "1sjgc9bxh63kkdp59nbirx3xazr02ia5yhp4f4a0jnq1hj465wsc"))))
+ "1yckx2csqswghiy9nfj03cybmza8104nmnpbpcc9ngwlbmakn9i6"))))
(build-system haskell-build-system)
(inputs
`(("ghc-hashable" ,ghc-hashable)))
@@ -7978,9 +7978,9 @@ API.")
`(("ghc-hunit" ,ghc-hunit)
("ghc-quickcheck" ,ghc-quickcheck)
("ghc-tagged" ,ghc-tagged)
- ("ghc-test-framework" ,ghc-test-framework)
- ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
- ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
+ ("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
(home-page "https://github.com/jaspervdj/psqueues")
(synopsis "Pure priority search queues")
(description "The psqueues package provides