summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-09-08 13:27:58 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-09-13 22:25:53 +0200
commitaadf4d38472e5438f9c2ed5a2a39a3fcc2b3557a (patch)
tree84c3b54c415ef7bbc97a9693f0b2c79d205bce04 /gnu
parent157547f4a437e3d497eefe8673e816f225cb6214 (diff)
downloadguix-patches-aadf4d38472e5438f9c2ed5a2a39a3fcc2b3557a.tar
guix-patches-aadf4d38472e5438f9c2ed5a2a39a3fcc2b3557a.tar.gz
gnu: Add emacs-caml.
* gnu/packages/emacs-xyz.scm (emacs-caml): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f8a01befc9..41cc19878a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2773,6 +2773,34 @@ the ability to jump forward and backward to the next bookmark.")
Emacs buffer.")
(license license:gpl3+)))
+(define-public emacs-caml
+ (package
+ (name "emacs-caml")
+ (version "4.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.nongnu.org/nongnu/caml-"
+ version ".tar"))
+ (sha256
+ (base32
+ "00ldvz6r10vwwmk6f3az534p0340ywn7knsg2bmvbvh3q51vyl9i"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ocaml/caml-mode")
+ (synopsis "Caml mode for GNU Emacs")
+ (description
+ "This package provides a major mode for editing OCaml code in Emacs.
+Some of its major features include:
+
+@itemize
+@item syntax highlighting (font lock);
+@item automatic indentation;
+@item querying the type of expressions (using compiler generated annot files);
+@item running an OCaml REPL within Emacs;
+@item scanning of declarations and placing them in a menu.
+@end itemize")
+ (license license:gpl2+)))
+
(define-public emacs-caps-lock
(package
(name "emacs-caps-lock")