summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-06-05 12:46:20 +0800
committer宋文武 <iyzsong@gmail.com>2015-06-05 12:46:20 +0800
commit4a79e256f0c694b3e86deb64e554f23f05274009 (patch)
treeabb8b6013384ce85b44f533ee9bd3066462ffdb4 /gnu
parent4becc7927320378f8ecbdf111adf57070851f656 (diff)
downloadguix-patches-4a79e256f0c694b3e86deb64e554f23f05274009.tar
guix-patches-4a79e256f0c694b3e86deb64e554f23f05274009.tar.gz
gnu: Add devhelp.
* gnu/packages/gnome.scm (devhelp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 35af94f4fc..34658e129f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -66,6 +66,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages compression)
#:use-module (gnu packages web)
+ #:use-module (gnu packages webkit)
#:use-module (gnu packages xorg)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages mail)
@@ -2407,3 +2408,30 @@ playlists in a variety of formats.")
"Aisleriot (also known as Solitaire or sol) is a collection of card games
which are easy to play with the aid of a mouse.")
(license license:gpl3+)))
+
+(define-public devhelp
+ (package
+ (name "devhelp")
+ (version "3.16.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0i8kyh86hzwxs8dm047ivghl2b92vigdxa3x4pk4ha0whpk38g37"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("webkitgtk" ,webkitgtk)))
+ (home-page "https://wiki.gnome.org/Apps/Devhelp")
+ (synopsis "API documentation browser for GNOME")
+ (description
+ "Devhelp is an API documentation browser for GTK+ and GNOME. It works
+natively with GTK-Doc (the API reference system developed for GTK+ and used
+throughout GNOME for API documentation).")
+ (license license:gpl2+)))