summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-09-11 02:55:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-09-18 11:33:25 +0200
commit649cf27c01748cbbea4d5410f860c559d2d3e62c (patch)
treef69bdfeed7492caf0cdce4691c6b6daab331d983 /gnu
parent5a87093fd57f136cb9091d2d97d3674e8dac6e61 (diff)
downloadguix-patches-649cf27c01748cbbea4d5410f860c559d2d3e62c.tar
guix-patches-649cf27c01748cbbea4d5410f860c559d2d3e62c.tar.gz
gnu: Add r-rcpproll.
* gnu/packages/cran.scm (r-rcpproll): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1256eb30bd..7d0e2b3276 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1126,3 +1126,27 @@ multivariate and 5 functional classification problems are included.")
coefficient between records, and to compute the top-n matches between records.
Core algorithms are executed in parallel on systems supporting OpenMP.")
(license license:gpl3)))
+
+(define-public r-rcpproll
+ (package
+ (name "r-rcpproll")
+ (version "0.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RcppRoll" version))
+ (sha256
+ (base32
+ "19xzvxym8zbighndygkq4imfwc0abh4hqyq3qrr8aakyd096iisi"))))
+ (properties `((upstream-name . "RcppRoll")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)))
+ (home-page "http://cran.r-project.org/web/packages/RcppRoll")
+ (synopsis "Efficient rolling and windowed operations")
+ (description
+ "This package provides fast and efficient routines for common rolling /
+windowed operations. Routines for the efficient computation of windowed mean,
+median, sum, product, minimum, maximum, standard deviation and variance are
+provided.")
+ (license license:gpl2+)))