summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-03 22:00:01 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-04 00:11:08 +0200
commit3a5b1cc32a4f9dd1128f373c087d37aad95ed309 (patch)
treefbbf5a8c770bf1144e7114f354cb028631aa0d3c /gnu
parent347227efc13d3389f1a40084ea28297ce1a9e14d (diff)
downloadguix-patches-3a5b1cc32a4f9dd1128f373c087d37aad95ed309.tar
guix-patches-3a5b1cc32a4f9dd1128f373c087d37aad95ed309.tar.gz
gnu: flightgear: Build with qt-build-system.
* gnu/packages/games.scm (flightgear)[build-system]: Switch to qt-build-system. [arguments]: Remove 'wrap-executable phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm19
1 files changed, 2 insertions, 17 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 48722230c4..f601e96035 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9313,7 +9313,7 @@ and also provides the base for the FlightGear Flight Simulator.")
(for-each delete-file-recursively
'("3rdparty/sqlite3/"))
#t))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(arguments
`(#:configure-flags
(list "-DSYSTEM_SQLITE=ON"
@@ -9325,21 +9325,6 @@ and also provides the base for the FlightGear Flight Simulator.")
#:tests? #f
#:phases
(modify-phases %standard-phases
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out "/bin/fgfs")
- `("QT_PLUGIN_PATH" ":" prefix
- ,(map (lambda (label)
- (string-append (assoc-ref inputs label)
- "/lib/qt5/plugins"))
- '("qtbase" "qtdeclarative" "qtsvg")))
- `("QML2_IMPORT_PATH" ":" prefix
- ,(map (lambda (label)
- (string-append (assoc-ref inputs label)
- "/lib/qt5/qml"))
- '("qtdeclarative" "qtsvg"))))
- #t)))
(add-after 'install 'install-data
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((share (string-append (assoc-ref outputs "out") "/share/flightgear")))
@@ -9379,7 +9364,7 @@ and also provides the base for the FlightGear Flight Simulator.")
(sha256
(base32
"0n5mw9vw1snab16c1y3i9ylkiv54az57bs2mvpq20hhg5hdiagqj"))))))
- (home-page "https://home.flightgear.org/")
+ (home-page "https://www.flightgear.org/")
(synopsis "Flight simulator")
(description "The goal of the FlightGear project is to create a
sophisticated flight simulator framework for use in research or academic