summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-01 19:46:45 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-01 19:46:45 +0200
commit8b79a5472deb0bb88adfa87d5144721b4b671a96 (patch)
treeeaf004e52a25bb6de1926579a8838c4b6ee0ccec /gnu
parentfca300c8ea62ba7cbd2efdec12faa61884a4f6af (diff)
downloadguix-patches-8b79a5472deb0bb88adfa87d5144721b4b671a96.tar
guix-patches-8b79a5472deb0bb88adfa87d5144721b4b671a96.tar.gz
gnu: Add Gtk+ 3.
* gnu/packages/gtk.scm (gtk+): Switch to version 3.10.0. * gnu/packages/gtk.scm (gtk+-2): New name for version 2.24.20.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f9f8b66328..cef9d73b26 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -31,6 +31,7 @@
#:use-module (gnu packages libpng)
#:use-module (gnu packages libtiff)
#:use-module (gnu packages pdf)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages guile)
@@ -242,7 +243,7 @@ is part of the GNOME accessibility project.")
(license license:lgpl2.0+)
(home-page "https://projects.gnome.org/accessibility/")))
-(define-public gtk+
+(define-public gtk+-2
(package
(name "gtk+")
(version "2.24.20")
@@ -280,6 +281,42 @@ application suites.")
(license license:lgpl2.0+)
(home-page "http://www.gtk.org/")))
+(define-public gtk+
+ (package (inherit gtk+-2)
+ (version "3.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gtk+/"
+ (string-take version 4) "/gtk+-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1zjkbjvp6ay08107r6zfsrp39x7qfadbd86p3hs5v4ydc2rzwnb5"))))
+ (inputs
+ `(("at-spi2-atk" ,at-spi2-atk)
+ ("libxi" ,libxi)
+ ("libxinerama" ,libxinerama)
+ ("libxml2" ,libxml2)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python-wrapper" ,python-wrapper)
+ ("xorg-server" ,xorg-server)))
+ (arguments
+ `(#:configure-flags '("--enable-x11-backend") ; should not be needed in > 3.10.0
+ #:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key #:allow-other-keys #:rest args)
+ (let ((configure (assoc-ref %standard-phases 'configure)))
+ ;; Disable most tests, failing in the chroot with the message:
+ ;; D-Bus library appears to be incorrectly set up; failed to read
+ ;; machine uuid: Failed to open "/etc/machine-id": No such file or
+ ;; directory.
+ ;; See the manual page for dbus-uuidgen to correct this issue.
+ (substitute* "testsuite/Makefile.in"
+ (("SUBDIRS = gdk gtk a11y css reftests") "SUBDIRS = gdk"))
+ (apply configure args)))
+ %standard-phases)))))
;;;
;;; Guile bindings.