summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-07 23:45:55 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-07 23:45:55 +0200
commit6666350320098453a211cd98d041252162063c32 (patch)
tree7ebaab00cc124552c945ebfe4dd1578553ed0fad /gnu
parentdd8abc295f93e177d70cbbd661951bb0cc87f79b (diff)
downloadguix-patches-6666350320098453a211cd98d041252162063c32.tar
guix-patches-6666350320098453a211cd98d041252162063c32.tar.gz
gnu: Add Cairomm.
* gnu/packages/gtk.scm (cairomm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 455d568490..44687e0072 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -382,3 +382,36 @@ importantly, it is pleasant to use. You get a powerful and well-maintained
graphics library with all of the benefits of Scheme: memory management,
exceptions, macros, and a dynamic programming environment.")
(license license:lgpl3+)))
+
+
+;;;
+;;; C++ bindings.
+;;;
+
+(define-public cairomm
+ (package
+ (name "cairomm")
+ (version "1.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://cairographics.org/releases/cairomm-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "13rrp96px95m6xnvmsaqb0wcqsnizg3bz334k0yhlyxf7v29d386"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; The examples lack -lcairo.
+ '(#:make-flags '("LDFLAGS=-lcairo")))
+ (inputs `(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("libsigc++" ,libsigc++)
+ ("freetype" ,freetype)
+ ("fontconfig" ,fontconfig)
+ ("cairo" ,cairo)))
+ (home-page "http://cairographics.org/")
+ (synopsis "C++ bindings to the Cairo 2D graphics library")
+ (description
+ "Cairomm provides a C++ programming interface to the Cairo 2D graphics
+library.")
+ (license license:lgpl2.0+)))