summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-10-07 22:37:17 -0400
committerMark H Weaver <mhw@netris.org>2015-10-07 22:41:18 -0400
commit2ab5e39d22dd9698c33a7a6ed8d5266f596f68e0 (patch)
treef178039be3c0e3f808389bd218d7cf34ae31ec63 /gnu
parent7ab73c4addad7cf5358b988943871ea85192f692 (diff)
downloadguix-patches-2ab5e39d22dd9698c33a7a6ed8d5266f596f68e0.tar
guix-patches-2ab5e39d22dd9698c33a7a6ed8d5266f596f68e0.tar.gz
gnu: libvpx: Set size limit to avoid CVE-2015-1258.
* gnu/packages/video.scm (libvpx)[arguments]: Add "--size-limit" argument to configure.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 5ec225eb2f..45c10998f5 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -777,6 +777,8 @@ projects while introducing many more.")
(zero? (system* "./configure"
"--enable-shared"
"--as=yasm"
+ ;; Limit size to avoid CVE-2015-1258
+ "--size-limit=16384x16384"
(string-append "--prefix=" out)))))
%standard-phases)
#:tests? #f)) ; no check target