summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-06-08 13:20:29 +0000
committerLeo Famulari <leo@famulari.name>2021-06-08 13:20:43 -0400
commit65e4a610aee167720a1917ea31926b285a93f5b6 (patch)
tree4c260d906d19ac0de2dfb31e672f048faae7e3d3 /gnu
parent74c70553394e32f7b6d5fa56da3bf3b18623c70f (diff)
downloadguix-patches-65e4a610aee167720a1917ea31926b285a93f5b6.tar
guix-patches-65e4a610aee167720a1917ea31926b285a93f5b6.tar.gz
gnu: python-pyzmq: Enable tests.
* gnu/packages/python-xyz.scm (python-pyzmq)[arguments]: Remove #:tests?. Add new 'build-extensions' phase to build Cython extensions before tests. [native-inputs]: Remove python-nose. Add python-cython and python-pytest. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bfc7af8f83..543f25848a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9124,14 +9124,18 @@ applications.")
(arguments
`(#:configure-flags
(list (string-append "--zmq=" (assoc-ref %build-inputs "zeromq")))
- ;; FIXME: You must build pyzmq with 'python setup.py build_ext
- ;; --inplace' for 'python setup.py test' to work.
- #:tests? #f))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ ;; Cython extensions have to be built before running the tests.
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
(inputs
`(("zeromq" ,zeromq)))
(native-inputs
`(("pkg-config" ,pkg-config)
- ("python-nose" ,python-nose)))
+ ("python-cython" ,python-cython)
+ ("python-pytest" ,python-pytest)))
(home-page "https://github.com/zeromq/pyzmq")
(synopsis "Python bindings for 0MQ")
(description