summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-06-05 21:22:01 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-06-15 09:53:27 +0200
commit324b0040f4ac493ef11f82712db2c9abcc6b92ca (patch)
tree32e656d3efd2adb495d7067fe9357253b91f4718 /gnu
parentd1e7ca2df8c0e0dd601079c77f67ba6828cec08a (diff)
downloadguix-patches-324b0040f4ac493ef11f82712db2c9abcc6b92ca.tar
guix-patches-324b0040f4ac493ef11f82712db2c9abcc6b92ca.tar.gz
gnu: Move desktop-file-utils to (gnu packages freedesktop).
* gnu/packages/gnome.scm (desktop-file-utils): Move from here ... * gnu/packages/freedesktop.scm (desktop-file-utils): ... to here. * gnu/packages/engineering.scm: Import (gnu packages freedesktop). * gnu/packages/game-development.scm: Import (gnu packages freedesktop). * gnu/packages/xfce.scm: Import (gnu packages freedesktop).
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/engineering.scm1
-rw-r--r--gnu/packages/freedesktop.scm32
-rw-r--r--gnu/packages/game-development.scm1
-rw-r--r--gnu/packages/gnome.scm32
-rw-r--r--gnu/packages/xfce.scm1
5 files changed, 35 insertions, 32 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 7568a1a9c3..c171e2629a 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -44,6 +44,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gd)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index e4b773078f..a9a7e08da1 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -968,3 +968,35 @@ library to access fingerprint readers, over the D-Bus interprocess
communication bus. This daemon layer above libfprint solves problems related
to applications simultaneously competing for fingerprint readers.")
(license license:gpl2+)))
+
+(define-public desktop-file-utils
+ (package
+ (name "desktop-file-utils")
+ (version "0.23")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://www.freedesktop.org/software/" name
+ "/releases/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "119kj2w0rrxkhg4f9cf5waa55jz1hj8933vh47vcjipcplql02bc"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)))
+ (home-page "http://www.freedesktop.org/wiki/Software/desktop-file-utils/")
+ (synopsis "Utilities for working with desktop entries")
+ (description
+ "This package contains a few command line utilities for working with
+desktop entries:
+
+desktop-file-validate: validates a desktop file and prints warnings/errors
+ about desktop entry specification violations.
+
+desktop-file-install: installs a desktop file to the applications directory,
+ optionally munging it a bit in transit.
+
+update-desktop-database: updates the database containing a cache of MIME types
+ handled by desktop files.")
+ (license license:gpl2+)))
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 5253d0c919..89db6427b0 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnunet)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a5d7c39387..20222ed9be 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -736,38 +736,6 @@ Specification, the icon naming utility maps the icon names used by the
GNOME and KDE desktops to the icon names proposed in the specification.")
(license license:lgpl2.1+)))
-(define-public desktop-file-utils
- (package
- (name "desktop-file-utils")
- (version "0.23")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://www.freedesktop.org/software/" name
- "/releases/" name "-" version ".tar.xz"))
- (sha256
- (base32
- "119kj2w0rrxkhg4f9cf5waa55jz1hj8933vh47vcjipcplql02bc"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (inputs
- `(("glib" ,glib)))
- (home-page "http://www.freedesktop.org/wiki/Software/desktop-file-utils/")
- (synopsis "Utilities for working with desktop entries")
- (description
- "This package contains a few command line utilities for working with
-desktop entries:
-
-desktop-file-validate: validates a desktop file and prints warnings/errors
- about desktop entry specification violations.
-
-desktop-file-install: installs a desktop file to the applications directory,
- optionally munging it a bit in transit.
-
-update-desktop-database: updates the database containing a cache of MIME types
- handled by desktop files.")
- (license license:gpl2+)))
-
(define-public gnome-icon-theme
(package
(name "gnome-icon-theme")
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index c8786dd69b..d7d1372dd2 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -39,6 +39,7 @@
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages web)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages image)
#:use-module (gnu packages gnome)
#:use-module (gnu packages pdf)