summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-08 01:02:07 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-08 01:13:39 +0100
commit1e1cba00d50eff257ca919c6b0765985a59f4589 (patch)
treed8374115d69f284c6f9713b879187556731d6cdc /gnu
parent8d8272dd474abebed4d98b9b14e525073c6dc436 (diff)
downloadguix-patches-1e1cba00d50eff257ca919c6b0765985a59f4589.tar
guix-patches-1e1cba00d50eff257ca919c6b0765985a59f4589.tar.gz
gnu: libaio: Fix cross-compilation.
* gnu/packages/linux.scm (libaio)[arguments]: Rewrite as G-expression to avoid %OUTPUT when cross-compiling.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm27
1 files changed, 16 insertions, 11 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f67dd85572..aea97b298a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5224,17 +5224,22 @@ Linux Device Mapper multipathing driver:
"14mlqdapjqq1dhpkdgy5z83mvsaz36fcxca7a4z6hinmr7r6415b"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "prefix=" %output)
- (string-append
- "CC=" (if target
- (string-append (assoc-ref %build-inputs "cross-gcc")
- "/bin/" target "-gcc")
- "gcc"))))
- #:test-target "partcheck" ; need root for a full 'check'
- #:phases
- (modify-phases %standard-phases (delete 'configure)))) ; no configure script
+ (list #:make-flags
+ #~(let ((target #$(%current-target-system)))
+ ;; XXX TODO: Replace with simply #$OUTPUT on core-updates.
+ (list (string-append "prefix=" #$(if (%current-target-system)
+ #~#$output
+ #~%output))
+ (string-append
+ "CC=" (if target
+ (string-append (assoc-ref %build-inputs
+ "cross-gcc")
+ "/bin/" target "-gcc")
+ "gcc"))))
+ #:test-target "partcheck" ; need root for a full 'check'
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
(home-page "https://pagure.io/libaio")
(synopsis "Linux-native asynchronous I/O access library")
(description