summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:26:18 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:39:00 +0200
commit0eaa75c8117b4e91475d7c4ad9960b925cef5d56 (patch)
tree14b996b30b5d1405694b6f9c44aae412d22126eb /gnu
parentcc1dbea883fed7515130144a2413c49c11c5352f (diff)
downloadguix-patches-0eaa75c8117b4e91475d7c4ad9960b925cef5d56.tar
guix-patches-0eaa75c8117b4e91475d7c4ad9960b925cef5d56.tar.gz
gnu: r-rhdf5: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-rhdf5): Move from here... * gnu/packages/bioconductor.scm (r-rhdf5): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm39
-rw-r--r--gnu/packages/bioinformatics.scm39
2 files changed, 39 insertions, 39 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index a6d0350da9..5ae045456a 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3713,6 +3713,45 @@ reports together for a particular project that can be viewed in a web
browser.")
(license license:artistic2.0)))
+(define-public r-rhdf5
+ (package
+ (name "r-rhdf5")
+ (version "2.34.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "rhdf5" version))
+ (sha256
+ (base32
+ "0almr1vscrgj5g4dyrags131wia2pmdbdidlpskbgm44ha6hpmqi"))))
+ (build-system r-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-linking
+ (lambda _
+ (substitute* "src/Makevars"
+ ;; This is to avoid having a plain directory on the list of
+ ;; libraries to link.
+ (("\\(RHDF5_LIBS\\)" match)
+ (string-append match "/libhdf5.a")))
+ #t)))))
+ (propagated-inputs
+ `(("r-rhdf5filters" ,r-rhdf5filters)
+ ("r-rhdf5lib" ,r-rhdf5lib)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://bioconductor.org/packages/rhdf5")
+ (synopsis "HDF5 interface to R")
+ (description
+ "This R/Bioconductor package provides an interface between HDF5 and R.
+HDF5's main features are the ability to store and access very large and/or
+complex datasets and a wide variety of metadata on mass storage (disk) through
+a completely portable file format. The rhdf5 package is thus suited for the
+exchange of large and/or complex datasets between R and other software
+package, and for letting R applications work on datasets that are larger than
+the available RAM.")
+ (license license:artistic2.0)))
+
(define-public r-rhdf5filters
(package
(name "r-rhdf5filters")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c144344dc7..a241a83c80 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8164,45 +8164,6 @@ bound and non bound genomic regions to accurately identify transcription
factors bound at the specific regions.")
(license license:gpl2+)))
-(define-public r-rhdf5
- (package
- (name "r-rhdf5")
- (version "2.34.0")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "rhdf5" version))
- (sha256
- (base32
- "0almr1vscrgj5g4dyrags131wia2pmdbdidlpskbgm44ha6hpmqi"))))
- (build-system r-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-linking
- (lambda _
- (substitute* "src/Makevars"
- ;; This is to avoid having a plain directory on the list of
- ;; libraries to link.
- (("\\(RHDF5_LIBS\\)" match)
- (string-append match "/libhdf5.a")))
- #t)))))
- (propagated-inputs
- `(("r-rhdf5filters" ,r-rhdf5filters)
- ("r-rhdf5lib" ,r-rhdf5lib)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (home-page "https://bioconductor.org/packages/rhdf5")
- (synopsis "HDF5 interface to R")
- (description
- "This R/Bioconductor package provides an interface between HDF5 and R.
-HDF5's main features are the ability to store and access very large and/or
-complex datasets and a wide variety of metadata on mass storage (disk) through
-a completely portable file format. The rhdf5 package is thus suited for the
-exchange of large and/or complex datasets between R and other software
-package, and for letting R applications work on datasets that are larger than
-the available RAM.")
- (license license:artistic2.0)))
-
(define-public emboss
(package
(name "emboss")