summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-09-09 19:35:20 -0400
committerKei Kebreau <kkebreau@posteo.net>2020-09-09 21:00:15 -0400
commitf98ea63204680bfd29f487200f9c048c197f9e28 (patch)
tree6ee61dd94ea90160d97d09a419ad6a30ccb471e6 /gnu
parent2110cd1332aee5439c32413f01483055ef91b339 (diff)
downloadguix-patches-f98ea63204680bfd29f487200f9c048c197f9e28.tar
guix-patches-f98ea63204680bfd29f487200f9c048c197f9e28.tar.gz
gnu: retux: Update to 1.4.
* gnu/packages/games.scm (retux): Update to 1.4. [source, home-page]: Update URLs. [arguments]: Update 'install phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm21
1 files changed, 8 insertions, 13 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1cd0df0dd0..15b1857f6c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2016, 2017 Rodger Fox <thylakoid@openmailbox.org>
;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
;;; Copyright © 2016 Albin Söderqvist <albin@fripost.org>
-;;; Copyright © 2016, 2017, 2018, 2019 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
@@ -1811,15 +1811,16 @@ Every puzzle has a complete solution, although there may be more than one.")
(define-public retux
(package
(name "retux")
- (version "1.3.6")
+ (version "1.4")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://savannah/retux/"
+ (uri (string-append "https://github.com/retux-game/retux/"
+ "releases/download/v"
(version-major+minor version) "/retux-"
version "-src.tar.gz"))
(sha256
(base32
- "01bidh4zisjp3nc436x0g85v60dvwb3ig37i7y01sa71j8fm4fmb"))))
+ "1hxy1pvlxhk0ci3wh2i3mmr82faqdjnnxsiwwr5gcr93nfnw9w5f"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ; no check target
@@ -1831,28 +1832,22 @@ Every puzzle has a complete solution, although there may be more than one.")
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
- (data (string-append out "/share/retux"))
- (doc (string-append out "/share/doc/retux")))
+ (data (string-append out "/share/retux")))
(mkdir-p bin)
(substitute* "retux.py"
;; Use the correct data directory.
(("os\\.path\\.join\\(os\\.path\\.dirname\\(__file__\\), \"data\"\\),")
- (string-append "\"" data "\","))
- ;; Use Python 3 so the patch-shebangs phase works properly.
- ((".*python2.*") "#!/usr/bin/python3"))
+ (string-append "\"" data "\",")))
(copy-file "retux.py" (string-append bin "/retux"))
-
(copy-recursively "data" data)
-
- (install-file "COPYING" doc)
#t))))))
(inputs
`(("python-sge-pygame" ,python-sge-pygame)
("python-six" ,python-six)
("python-xsge" ,python-xsge)))
- (home-page "http://retux.nongnu.org")
+ (home-page "https://retux-game.github.io/")
(synopsis "Action platformer game")
(description
"ReTux is an action platformer loosely inspired by the Mario games,