summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-03 18:32:56 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-03 22:28:49 +0200
commitabb53e6f871cbf79fe24b7052fb41c8aff2f65ac (patch)
tree473bd6a070536e951bf581cd0e818f10f95026a7 /gnu
parentd00b83fb8a49581f08dc5676322c5decdcc64dfd (diff)
downloadguix-patches-abb53e6f871cbf79fe24b7052fb41c8aff2f65ac.tar
guix-patches-abb53e6f871cbf79fe24b7052fb41c8aff2f65ac.tar.gz
gnu: python-beautifulsoup4: Update to 4.7.1.
* gnu/packages/python-xyz.scm (python-beautifulsoup4): Update to 4.7.1. [native-inputs]: Add PYTHON-SOUPSIEVE.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bd706703c8..809f594520 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5381,14 +5381,14 @@ libxml2 and libxslt.")
(define-public python-beautifulsoup4
(package
(name "python-beautifulsoup4")
- (version "4.6.3")
+ (version "4.7.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "beautifulsoup4" version))
(sha256
(base32
- "041dhalzjciw6qyzzq7a2k4h1yvyk76xigp35hv5ibnn448ydy4h"))))
+ "0j2kycz2dxgx68xzjm7rxg5xn6v61gq5ifvxyg99slmqkybnal4l"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -5400,6 +5400,8 @@ libxml2 and libxslt.")
;; distribution.
(replace 'check
(lambda _ (invoke "./convert-py3k"))))))
+ (native-inputs
+ `(("python-soupsieve" ,python-soupsieve)))
(home-page
"https://www.crummy.com/software/BeautifulSoup/bs4/")
(synopsis