summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-09-09 16:59:42 +0200
committerRoel Janssen <roel@gnu.org>2020-09-09 16:59:42 +0200
commita9401b4c948552d6a5a95bbd295e61871f4c6d74 (patch)
tree53a39943db51927760c938cd671d8f11c8f36e66 /gnu
parent1f56ec08af704bdc7aa3e143bf5ce351c5306dea (diff)
downloadguix-patches-a9401b4c948552d6a5a95bbd295e61871f4c6d74.tar
guix-patches-a9401b4c948552d6a5a95bbd295e61871f4c6d74.tar.gz
gnu: Add r-useful.
* gnu/packages/cran.scm (r-useful): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3b13bbd585..8f7e379e42 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -3724,6 +3724,36 @@ algorithm. The interface of @code{ucminf} is designed for easy interchange
with the package @code{optim}.")
(license license:gpl2+)))
+(define-public r-useful
+ (package
+ (name "r-useful")
+ (version "1.2.6")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "useful" version))
+ (sha256
+ (base32
+ "0n50v1q75k518sq23id14jphwla35q4sasahrnrnllwrachl67v1"))))
+ (properties `((upstream-name . "useful")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertthat" ,r-assertthat)
+ ("r-dplyr" ,r-dplyr)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-magrittr" ,r-magrittr)
+ ("r-matrix" ,r-matrix)
+ ("r-plyr" ,r-plyr)
+ ("r-purrr" ,r-purrr)
+ ("r-scales" ,r-scales)))
+ (home-page "https://github.com/jaredlander/useful")
+ (synopsis "A Collection of Handy, Useful Functions")
+ (description "This package provides a set of little functions that have been
+found useful to do little odds and ends such as plotting the results of K-means
+clustering, substituting special text characters, viewing parts of a
+@code{data.frame}, constructing formulas from text and building design and
+response matrices.")
+ (license license:bsd-3)))
+
(define-public r-ordinal
(package
(name "r-ordinal")