summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-05-10 15:47:29 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-05-10 16:44:01 +0200
commit55acb372e38051399de52589407ca8cf7d04398d (patch)
tree983184825354a95ec42cc9614c932829bea34f6d /gnu
parent62ec02bf21a88330d5b9defef1152d6ec1e8541f (diff)
downloadguix-patches-55acb372e38051399de52589407ca8cf7d04398d.tar
guix-patches-55acb372e38051399de52589407ca8cf7d04398d.tar.gz
gnu: e2fsprogs: Use 'modify-phases' syntax.
* gnu/packages/linux.scm (e2fsprogs)[arguments]<#:phases>: Use 'modify-phases'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm56
1 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7a7eb6dfbf..0495f045f4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -695,34 +695,34 @@ slabtop, and skill.")
(assoc-ref %outputs "out")
"/lib"))
- #:phases (alist-cons-before
- 'configure 'patch-shells
- (lambda _
- (substitute* "configure"
- (("/bin/sh (.*)parse-types.sh" _ dir)
- (string-append (which "sh") " " dir
- "parse-types.sh")))
- (substitute* (find-files "." "^Makefile.in$")
- (("#!/bin/sh")
- (string-append "#!" (which "sh")))))
- (alist-cons-after
- 'install 'install-libs
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib")))
- (and (zero? (system* "make" "install-libs"))
-
- ;; Make the .a writable so that 'strip' works.
- ;; Failing to do that, due to debug symbols, we
- ;; retain a reference to the final
- ;; linux-libre-headers, which refer to the
- ;; bootstrap binaries.
- (let ((archives (find-files lib "\\.a$")))
- (for-each (lambda (file)
- (chmod file #o666))
- archives)
- #t))))
- %standard-phases))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-shells
+ (lambda _
+ (substitute* "configure"
+ (("/bin/sh (.*)parse-types.sh" _ dir)
+ (string-append (which "sh") " " dir
+ "parse-types.sh")))
+ (substitute* (find-files "." "^Makefile.in$")
+ (("#!/bin/sh")
+ (string-append "#!" (which "sh"))))
+ #t))
+ (add-after 'install 'install-libs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib")))
+ (and (zero? (system* "make" "install-libs"))
+
+ ;; Make the .a writable so that 'strip' works.
+ ;; Failing to do that, due to debug symbols, we
+ ;; retain a reference to the final
+ ;; linux-libre-headers, which refer to the
+ ;; bootstrap binaries.
+ (let ((archives (find-files lib "\\.a$")))
+ (for-each (lambda (file)
+ (chmod file #o666))
+ archives)
+ #t))))))
;; FIXME: Tests work by comparing the stdout/stderr of programs, that
;; they fail because we get an extra line that says "Can't check if