summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-29 17:08:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-02 17:31:36 +0200
commitc6ab73e8ff357ea35c3d0ebf1b09c6c7be300a94 (patch)
tree38b0e8051faaa610054660b4f57a0fb5352bdb65 /gnu
parent6a703976f43bcfc3166df24163800b46d65186b7 (diff)
downloadguix-patches-c6ab73e8ff357ea35c3d0ebf1b09c6c7be300a94.tar
guix-patches-c6ab73e8ff357ea35c3d0ebf1b09c6c7be300a94.tar.gz
gnu: Add r-viridislite.
* gnu/packages/statistics.scm (r-viridislite): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 9cf79ef7c9..51294e5b3b 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3040,6 +3040,31 @@ black-and-white. They are also designed to be perceived by readers with the
most common form of color blindness.")
(license license:x11)))
+(define-public r-viridislite
+ (package
+ (name "r-viridislite")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "viridisLite" version))
+ (sha256
+ (base32
+ "1b0fhj8i1m9jsz91gzag60k7vy7kk5xkdg31rc3h3spq96l66psp"))))
+ (properties `((upstream-name . "viridisLite")))
+ (build-system r-build-system)
+ (home-page "https://github.com/sjmgarnier/viridisLite")
+ (synopsis "Default color maps from matplotlib")
+ (description
+ "This package is a port of the new @code{matplotlib} color maps ('viridis',
+'magma', 'plasma' and 'inferno') to R. matplotlib is a popular plotting
+library for Python. These color maps are designed in such a way that they
+will analytically be perfectly perceptually-uniform, both in regular form and
+also when converted to black-and-white. They are also designed to be
+perceived by readers with the most common form of color blindness. This is
+the 'lite' version of the more complete @code{viridis} package.")
+ (license license:expat)))
+
(define-public r-tidyr
(package
(name "r-tidyr")