summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-10-26 20:52:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-23 10:10:58 +0100
commit0ac4c0ca40d60f06f5871f02cdefe125464da9e9 (patch)
treebccc3490a72c318f76f4a6c0ce640fa5eae3dc06 /gnu
parente760a15d3523d798016ee4e66cb18d6217d0377f (diff)
downloadguix-patches-0ac4c0ca40d60f06f5871f02cdefe125464da9e9.tar
guix-patches-0ac4c0ca40d60f06f5871f02cdefe125464da9e9.tar.gz
gnu: Replace texlive-metafont-base with texlive-metafont.
* gnu/packages/tex.scm (texlive-metafont-base): Deprecate this variable in favor of... (texlive-metafont): ...this new variable. (texlive-cm, texlive-fonts-knuth-lib, texlive-fonts-latex, texlive-amsfonts, texlive-etex, texlive-base, texlive-fonts-ec, texlive-fonts-rsfs): Adjust references to texlive-metafont-base.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 19 insertions, 16 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3ace28bd25..85df70a465 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -551,9 +551,9 @@ to adapt the plain e-TeX source file to work with XeTeX and LuaTeX.")
(define-public texlive-generic-tex-ini-files
(deprecated-package "texlive-generic-tex-ini-files" texlive-tex-ini-files))
-(define-public texlive-metafont-base
+(define-public texlive-metafont
(package
- (name "texlive-metafont-base")
+ (name "texlive-metafont")
(version (number->string %texlive-revision))
(source (origin
(method svn-fetch)
@@ -605,6 +605,9 @@ to adapt the plain e-TeX source file to work with XeTeX and LuaTeX.")
build fonts using the Metafont system.")
(license license:knuth)))
+(define-public texlive-metafont-base
+ (deprecated-package "texlive-metafont-base" texlive-metafont))
+
(define-public texlive-fontinst
(let ((template (simple-texlive-package
"texlive-fontinst"
@@ -736,7 +739,7 @@ documents.")
`(modify-phases ,phases
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
- (let ((mf (assoc-ref inputs "texlive-metafont-base")))
+ (let ((mf (assoc-ref inputs "texlive-metafont")))
;; Tell mf where to find mf.base
(setenv "MFBASES" (string-append mf "/share/texmf-dist/web2c"))
;; Tell mf where to look for source files
@@ -780,7 +783,7 @@ documents.")
#t)))))))
(native-inputs
`(("texlive-bin" ,texlive-bin)
- ("texlive-metafont-base" ,texlive-metafont-base)))
+ ("texlive-metafont" ,texlive-metafont)))
(home-page "https://www.ctan.org/pkg/cm")
(synopsis "Computer Modern fonts for TeX")
(description "This package provides the Computer Modern fonts by Donald
@@ -882,7 +885,7 @@ Computers & Typesetting series.")
(delete 'configure)
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
- (let ((mf (assoc-ref inputs "texlive-metafont-base")))
+ (let ((mf (assoc-ref inputs "texlive-metafont")))
;; Tell mf where to find mf.base
(setenv "MFBASES"
(string-append mf "/share/texmf-dist/web2c"))
@@ -916,7 +919,7 @@ Computers & Typesetting series.")
#t))))))
(native-inputs
`(("texlive-bin" ,texlive-bin)
- ("texlive-metafont-base" ,texlive-metafont-base)))
+ ("texlive-metafont" ,texlive-metafont)))
(home-page "https://www.ctan.org/pkg/knuth-lib")
(synopsis "Small library of METAFONT sources")
(description "This is a collection of core TeX and METAFONT macro files
@@ -951,7 +954,7 @@ fonts.")
(delete 'configure)
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
- (let ((mf (assoc-ref inputs "texlive-metafont-base")))
+ (let ((mf (assoc-ref inputs "texlive-metafont")))
;; Tell mf where to find mf.base
(setenv "MFBASES" (string-append mf "/share/texmf-dist/web2c"))
;; Tell mf where to look for source files
@@ -990,7 +993,7 @@ fonts.")
#t))))))
(native-inputs
`(("texlive-bin" ,texlive-bin)
- ("texlive-metafont-base" ,texlive-metafont-base)
+ ("texlive-metafont" ,texlive-metafont)
("texlive-cm" ,texlive-cm)))
(home-page "https://www.ctan.org/pkg/latex-fonts")
(synopsis "Collection of fonts used in LaTeX distributions")
@@ -1176,7 +1179,7 @@ Taco Hoekwater.")
(native-inputs
`(("texlive-union" ,(texlive-union (list texlive-tex-fontinst-base
texlive-cm
- texlive-metafont-base)))))
+ texlive-metafont)))))
(home-page "https://www.ctan.org/pkg/amsfonts")
(synopsis "TeX fonts from the American Mathematical Society")
(description
@@ -1240,7 +1243,7 @@ output encodings, and features generation of clean UTF-8 patterns.")
;; Build tfm font.
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
- (let ((mf (assoc-ref inputs "texlive-metafont-base")))
+ (let ((mf (assoc-ref inputs "texlive-metafont")))
;; Tell mf where to find mf.base
(setenv "MFBASES" (string-append mf "/share/texmf-dist/web2c"))
;; Tell mf where to look for source files
@@ -1266,7 +1269,7 @@ output encodings, and features generation of clean UTF-8 patterns.")
#t))))))
(native-inputs
`(("texlive-bin" ,texlive-bin)
- ("texlive-metafont-base" ,texlive-metafont-base)
+ ("texlive-metafont" ,texlive-metafont)
("texlive-cm" ,texlive-cm)))
(home-page "https://www.ctan.org/pkg/etex")
(synopsis "Extended version of TeX")
@@ -3463,7 +3466,7 @@ packages.")
texlive-cm
texlive-cm-super ; to avoid bitmap fonts
texlive-fonts-latex
- texlive-metafont-base
+ texlive-metafont
texlive-latex-base
;; LaTeX packages from the "required" set.
texlive-latex-amsmath
@@ -4773,7 +4776,7 @@ in SGML; use maths minus in text as appropriate; simple Young tableaux.")
(delete 'configure)
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
- (let ((mf (assoc-ref inputs "texlive-metafont-base")))
+ (let ((mf (assoc-ref inputs "texlive-metafont")))
;; Tell mf where to find mf.base
(setenv "MFBASES" (string-append mf "/share/texmf-dist/web2c"))
;; Tell mf where to look for source files
@@ -4808,7 +4811,7 @@ in SGML; use maths minus in text as appropriate; simple Young tableaux.")
#t))))))
(native-inputs
`(("texlive-bin" ,texlive-bin)
- ("texlive-metafont-base" ,texlive-metafont-base)
+ ("texlive-metafont" ,texlive-metafont)
("texlive-cm" ,texlive-cm)))
(home-page "https://www.ctan.org/pkg/ec")
(synopsis "Computer modern fonts in T1 and TS1 encodings")
@@ -4990,7 +4993,7 @@ Adobe's basic set.")
(delete 'configure)
(replace 'build
(lambda* (#:key inputs #:allow-other-keys)
- (let ((mf (assoc-ref inputs "texlive-metafont-base")))
+ (let ((mf (assoc-ref inputs "texlive-metafont")))
;; Tell mf where to find mf.base
(setenv "MFBASES" (string-append mf "/share/texmf-dist/web2c"))
;; Tell mf where to look for source files
@@ -5025,7 +5028,7 @@ Adobe's basic set.")
#t))))))
(native-inputs
`(("texlive-bin" ,texlive-bin)
- ("texlive-metafont-base" ,texlive-metafont-base)
+ ("texlive-metafont" ,texlive-metafont)
("texlive-cm" ,texlive-cm)))
(home-page "https://www.ctan.org/pkg/rsfs")
(synopsis "Ralph Smith's Formal Script font")