summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2021-02-04 01:52:12 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2021-02-04 02:14:00 +0300
commitcc4e2cb2465012ab4b16198d99c8448c75432b31 (patch)
tree521b282b7c732045387deb28bc0543ab841e777f /gnu
parent051c1271209a1a0f9ff258f9034600d650e25ca8 (diff)
downloadguix-patches-cc4e2cb2465012ab4b16198d99c8448c75432b31.tar
guix-patches-cc4e2cb2465012ab4b16198d99c8448c75432b31.tar.gz
gnu: Add emacs-org-appear.
* gnu/packages/emacs-xyz.scm (emacs-org-appear): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6ed85abd84..ad97681210 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6424,6 +6424,29 @@ Cucumber tool) user stories. Also known by the name @code{cucumber.el}.")
@code{org-mode} to be rendered as UTF-8 characters.")
(license license:gpl3+)))
+(define-public emacs-org-appear
+ (let ((commit "19ea96e6e2ce01b8583b25a6e5579f1be207a119")
+ (revision "1"))
+ (package
+ (name "emacs-org-appear")
+ (version (git-version "0.0.1" revision commit)) ;no upstream release
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/awth13/org-appear")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "064kdb3z4zr9sa7qi5921cqh8vj226ifl8x1bkc59qd9a1p34ghd"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/awth13/org-appear")
+ (synopsis "Make invisible parts of Org fragments appear visible")
+ (description "This package enables automatic visibility toggling of
+org-mode elements depending on cursor position. Hidden fragment parts appear
+when the cursor enters a fragment and disappear when it leaves.")
+ (license license:expat))))
+
(define-public emacs-org-drill
(package
(name "emacs-org-drill")