summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-24 16:52:10 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-30 14:41:48 +0100
commita75bdfcec340cbb9d240b542e09ffb3d32ea658d (patch)
treeef3076a1bfac2857f1af52ed926aa73982170067 /gnu
parent2f9e0b68e1d4098fe8259ea5113c160b7008c5e2 (diff)
downloadguix-patches-a75bdfcec340cbb9d240b542e09ffb3d32ea658d.tar
guix-patches-a75bdfcec340cbb9d240b542e09ffb3d32ea658d.tar.gz
gnu: Add ruby-pry-editline.
* gnu/packages/ruby.scm (ruby-pry-editline): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a01eefc2ed..d0f6fe971d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1809,6 +1809,27 @@ kernel subsystem for monitoring changes to files and directories.")
(home-page "https://github.com/nex3/rb-inotify")
(license license:expat)))
+(define-public ruby-pry-editline
+ (package
+ (name "ruby-pry-editline")
+ (version "1.1.2")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "pry-editline" version))
+ (sha256
+ (base32
+ "1pjxyvdxvw41xw3yyl18pwzix8hbvn6lgics7qcfhjfsf1zs8x1z"))))
+ (build-system ruby-build-system)
+ (arguments `(#:tests? #f)) ; no tests included
+ (native-inputs
+ `(("bundler" ,bundler)))
+ (synopsis "Open the current REPL line in an editor")
+ (description
+ "This gem provides a plugin for the Ruby REPL to enable opening the
+current line in an external editor.")
+ (home-page "https://github.com/tpope/pry-editline")
+ (license license:expat)))
+
(define-public ruby-json
(package
(name "ruby-json")