summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-07 12:38:55 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-07 12:39:51 +0100
commit3121814ef1a8820b2561dbb1a20f2616cdc28a73 (patch)
tree4a0798c9887783c641e9e012f677c80b6710c768 /gnu
parenta9540107c646f53c9c40d726cf22f3ac3dddce8f (diff)
downloadguix-patches-3121814ef1a8820b2561dbb1a20f2616cdc28a73.tar
guix-patches-3121814ef1a8820b2561dbb1a20f2616cdc28a73.tar.gz
gnu: Add r-keggrest.
* gnu/packages/bioinformatics.scm (r-keggrest): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 804cb6e4e4..58ffbff633 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9430,6 +9430,30 @@ formats can be used as input to fastseg like expression set objects for
microarrays or GRanges for sequencing data.")
(license license:lgpl2.0+)))
+(define-public r-keggrest
+ (package
+ (name "r-keggrest")
+ (version "1.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "KEGGREST" version))
+ (sha256
+ (base32
+ "1i3i88lj57wvpgjf75a23msgfsjv8pr2b4j1faga276p4fsblkhj"))))
+ (properties `((upstream-name . "KEGGREST")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biostrings" ,r-biostrings)
+ ("r-httr" ,r-httr)
+ ("r-png" ,r-png)))
+ (home-page "https://bioconductor.org/packages/KEGGREST")
+ (synopsis "Client-side REST access to KEGG")
+ (description
+ "This package provides a package that provides a client interface to the
+@dfn{Kyoto Encyclopedia of Genes and Genomes} (KEGG) REST server.")
+ (license license:artistic2.0)))
+
(define-public r-qvalue
(package
(name "r-qvalue")