summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-07 13:47:20 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-07 19:34:25 +0200
commit2f17187ff35a6e7dd7c8e7864225d667129e1584 (patch)
tree9c36fcff95a7975a98f08442cb1bc6dd58164006 /gnu
parent6541673354f28b1375bef503373ee2169e1dc325 (diff)
downloadguix-patches-2f17187ff35a6e7dd7c8e7864225d667129e1584.tar
guix-patches-2f17187ff35a6e7dd7c8e7864225d667129e1584.tar.gz
gnu: mediainfo: Change order of custom phases.
* gnu/packages/video.scm (mediainfo)[arguments]: Change to the build directory before executing the autogen script.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 60469d6d89..fdc8b02a5a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2332,10 +2332,11 @@ MPEG-2, MPEG-4, DVD (VOB)...
#:phases
;; build scripts not in root of archive
(modify-phases %standard-phases
- (add-before 'configure 'pre-configure
+ (add-after 'unpack 'change-to-build-dir
(lambda _
- (chdir "Project/GNU/CLI")))
- (add-after 'unpack 'autogen
+ (chdir "Project/GNU/CLI")
+ #t))
+ (add-after 'change-to-build-dir 'autogen
(lambda _
(zero? (system* "sh" "autogen.sh")))))))
(home-page "https://mediaarea.net/en/MediaInfo")