summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-11-15 11:04:23 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-15 11:04:23 +0100
commitb02a9523b394a7683692c50ddf9c945d269881b7 (patch)
tree104c68df5aeb28a2349407ca1df89de7cac5119b /gnu
parent7e08be71ac39ff843173dc80fae98273527cd0b6 (diff)
downloadguix-patches-b02a9523b394a7683692c50ddf9c945d269881b7.tar
guix-patches-b02a9523b394a7683692c50ddf9c945d269881b7.tar.gz
gnu: emacs-flycheck-cpplint: Set cpplint path.
* gnu/packages/emacs-xyz.scm (emacs-flycheck-cpplint)[inputs]: Add cpplint. [arguments]: Add a set-cpplint-path phase to set the path of cpplint.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 52d6e9544b..7cb949eb84 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -91,6 +91,7 @@
#:use-module (gnu packages bash)
#:use-module (gnu packages cmake)
#:use-module (gnu packages code)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages dictionaries)
@@ -19850,6 +19851,17 @@ such as:
(sha256
(base32 "0l6sg83f6z8x2alnblpv03rj442sbnkkkcbf8i0agjmx3713a5yx"))))
(build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-cpplint-path
+ (lambda _
+ (substitute* "flycheck-google-cpplint.el"
+ (("\"cpplint.py\"")
+ (string-append "\"" (which "cpplint") "\"")))
+ #t)))))
+ (inputs
+ `(("cpplint" ,cpplint)))
(propagated-inputs
`(("flycheck-mode" ,emacs-flycheck)))
(synopsis "Google C++ checker for Flycheck")