summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-08 17:23:53 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-08 21:20:05 +0200
commita6e70f3f0c5bdeaeba87ee847e94e60be4cfc08d (patch)
tree68eec2b9e5eb3d7c4a561ace0518a01995ac31b2 /gnu
parenta5a90a98d8664c92bb8d744abfde6c68c342d364 (diff)
downloadguix-patches-a6e70f3f0c5bdeaeba87ee847e94e60be4cfc08d.tar
guix-patches-a6e70f3f0c5bdeaeba87ee847e94e60be4cfc08d.tar.gz
gnu: python-hpack: Respect "--without-tests".
* gnu/packages/python-web.scm (python-hpack)[arguments]<#:phases>{check}: Respect #:tests?. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index cdc5c13b09..acabe00846 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -877,12 +877,13 @@ into HTTP/2 frames.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "test" "-k"
- ;; This test will be fixed in the next version. See:
- ;; https://github.com/python-hyper/hpack/issues/168.
- "not test_get_by_index_out_of_range"))))))
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-vv" "test" "-k"
+ ;; This test will be fixed in the next version. See:
+ ;; https://github.com/python-hyper/hpack/issues/168.
+ "not test_get_by_index_out_of_range")))))))
(native-inputs
`(("python-pytest" ,python-pytest)))
(home-page "https://hyper.rtfd.org")