summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:14:59 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:19 +0300
commit6673bbef87e23f64ab6aba4b9e6977466f53379f (patch)
tree473cd2f35dc956fc09880c4f3d64867b544af010 /gnu
parentc498ff56d33ce4edec9a6f2a14c96860f9718237 (diff)
downloadguix-patches-6673bbef87e23f64ab6aba4b9e6977466f53379f.tar
guix-patches-6673bbef87e23f64ab6aba4b9e6977466f53379f.tar.gz
gnu: Add emacs-stickyfunc-enhance.
* gnu/packages/emacs.scm (emacs-stickyfunc-enhance): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 2482a37bf5..b01c4228bb 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10171,3 +10171,29 @@ interactive loop.")
(synopsis "Evaluation result overlays")
(description "@code{eros} provides evaluation result overlays.")
(license license:gpl3+))))
+
+(define-public emacs-stickyfunc-enhance
+ (let ((commit "13bdba51fcd83ccbc3267959d23afc94d458dcb0")
+ (revision "1"))
+ (package
+ (name "emacs-stickyfunc-enhance")
+ (version "0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tuhdo/semantic-stickyfunc-enhance.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "16dxjsr5nj20blww4xpd4jzgjprzzh1nwvb810ggdmp9paf4iy0g"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tuhdo/semantic-stickyfunc-enhance")
+ (synopsis "Enhancement to stock @code{semantic-stickyfunc-mode}")
+ (description
+ "@code{semantic-stickyfunc-mode} shows the function point is currently
+in at the first line of the current buffer. This is useful when you have a
+very long function that spreads more than a screen, and you don't have to
+scroll up to read the function name and then scroll down to original position.")
+ (license license:gpl3+))))