summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2021-08-02 19:00:38 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-08-04 12:19:56 +0200
commit567922b9b5d461ad8f8f7aebc11ec504ec7eccaf (patch)
tree9635254500b2335513bb2269aab6735cf4dbfdbc /gnu
parentd84b2cce5d9ced9ff4b04df16b661bc6f6b66741 (diff)
downloadguix-patches-567922b9b5d461ad8f8f7aebc11ec504ec7eccaf.tar
guix-patches-567922b9b5d461ad8f8f7aebc11ec504ec7eccaf.tar.gz
gnu: emacs-elpher: Update to 3.2.1.
* gnu/packages/emacs-xyz.scm (emacs-elpher): Update to 3.2.1. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm53
1 files changed, 25 insertions, 28 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 02d4289274..47ace455c9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25415,40 +25415,37 @@ it forcibly
(license license:gpl3+))))
(define-public emacs-elpher
- ;; No tagged release upstream, but the commit below corresponds to the 2.10.3
- ;; release.
- (let ((commit "b0272de36cea3e1cd41cd15a012c8141b4b04575"))
- (package
- (name "emacs-elpher")
- (version "2.10.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://thelambdalab.xyz/elpher.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1m6lq47i4j6k76f81vcch6akab9mqph7kna3fn356295fvgm7j7q"))))
- (build-system emacs-build-system)
- (native-inputs
- `(("texinfo" ,texinfo)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'install 'build-doc
- (lambda _
- (invoke "makeinfo" "elpher.texi"))))))
- (home-page "gopher://thelambdalab.xyz/1/projects/elpher/")
- (synopsis "Gopher and gemini client for Emacs")
- (description "Elpher is a full-featured gopher and gemini client for
+ (package
+ (name "emacs-elpher")
+ (version "3.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://thelambdalab.xyz/elpher.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1k0nv5afsf4lh71yvqpg2zcmlbsgwcim1s161c2h4gh4p05vjwyq"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("texinfo" ,texinfo)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'build-doc
+ (lambda _
+ (invoke "makeinfo" "elpher.texi"))))))
+ (home-page "gopher://thelambdalab.xyz/1/projects/elpher/")
+ (synopsis "Gopher and gemini client for Emacs")
+ (description "Elpher is a full-featured gopher and gemini client for
Emacs. Its features include intuitive keyboard and mouse-driven browsing,
out-of-the-box compatibility with evil-mode, clickable links in plain text,
caching of visited sites, pleasant and configurable visualization of Gopher
directories, direct visualisation of image files, jumping directly to links by
name (with autocompletion), a simple bookmark management system and
connections using TLS encryption.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-zerodark-theme
(package