summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-07 17:04:37 +0100
committerMarius Bakke <marius@gnu.org>2022-01-07 17:15:38 +0100
commit4a943cfdbe42d77a0a11ee8fa8f5c616a97e0911 (patch)
tree4d391d9c797317a092d12bc41aac0a2f13427050 /gnu
parentfed39f13f0a640f90d7e3bc0701aa165974f45cd (diff)
downloadguix-patches-4a943cfdbe42d77a0a11ee8fa8f5c616a97e0911.tar
guix-patches-4a943cfdbe42d77a0a11ee8fa8f5c616a97e0911.tar.gz
gnu: ungoogled-chromium: Update to 97.0.4692.71-1.
* gnu/packages/patches/ungoogled-chromium-system-ffmpeg.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/chromium.scm (%guix-patches): Add it. (%chromium-version): Set to 97.0.4692.71-1. (%ungoogled-origin, ungoogled-chromium): Update hashes.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/chromium.scm9
-rw-r--r--gnu/packages/patches/ungoogled-chromium-system-ffmpeg.patch18
3 files changed, 25 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b39d0ac039..ca95c9e488 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1875,6 +1875,7 @@ dist_patch_DATA = \
%D%/packages/patches/ungoogled-chromium-extension-search-path.patch \
%D%/packages/patches/ungoogled-chromium-ffmpeg-compat.patch \
%D%/packages/patches/ungoogled-chromium-RUNPATH.patch \
+ %D%/packages/patches/ungoogled-chromium-system-ffmpeg.patch \
%D%/packages/patches/ungoogled-chromium-system-nspr.patch \
%D%/packages/patches/unison-fix-ocaml-4.08.patch \
%D%/packages/patches/unknown-horizons-python-3.8-distro.patch \
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index 263f46a18c..ddf4d6b31a 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -336,7 +336,7 @@
(string-append "ungoogled-chromium-" category "-" name))))
(sha256 (base32 hash))))
-(define %chromium-version "96.0.4664.110")
+(define %chromium-version "97.0.4692.71")
(define %ungoogled-revision (string-append %chromium-version "-1"))
(define %arch-revision "db2157b84924ce84201a8245e68a02f7d55f6491")
(define %debian-revision "debian/90.0.4430.85-1")
@@ -367,7 +367,7 @@
(file-name (git-file-name "ungoogled-chromium" %ungoogled-revision))
(sha256
(base32
- "098mfcd1lr2hhlic0i1l5gxsq71axvqnn4gayr4r9j6nbj9byf4h"))))
+ "0a1172kj93lg3ip4im1s5s7bdm2q41w4m6ylyxc92w29rbhbxjxp"))))
(define %guix-patches
(list (local-file
@@ -384,6 +384,9 @@
(search-patch "ungoogled-chromium-ffmpeg-compat.patch")))
(local-file
(assume-valid-file-name
+ (search-patch "ungoogled-chromium-system-ffmpeg.patch")))
+ (local-file
+ (assume-valid-file-name
(search-patch "ungoogled-chromium-system-nspr.patch")))))
;; This is a source 'snippet' that does the following:
@@ -483,7 +486,7 @@
%chromium-version ".tar.xz"))
(sha256
(base32
- "1s3ilq0ik36qgqp7l88gfd1yx97zscn8yr2kprsrjfp9q8lrva9n"))
+ "0z7ximvm4a78kxyp4j0i2jzklxazpw6jcqi9jkaf8bvq9ga8kqca"))
(modules '((guix build utils)))
(snippet (force ungoogled-chromium-snippet))))
(build-system gnu-build-system)
diff --git a/gnu/packages/patches/ungoogled-chromium-system-ffmpeg.patch b/gnu/packages/patches/ungoogled-chromium-system-ffmpeg.patch
new file mode 100644
index 0000000000..1472206b02
--- /dev/null
+++ b/gnu/packages/patches/ungoogled-chromium-system-ffmpeg.patch
@@ -0,0 +1,18 @@
+Alias the av_stream_get_first_dts definition added by Chromium in
+their bundled fork.
+
+Taken from Arch Linux:
+
+ https://github.com/archlinux/svntogit-packages/blob/38fd5d2f2e0ade932aa7a80b7dea26215fc41854/trunk/unbundle-ffmpeg-av_stream_get_first_dts.patch
+
+diff --git a/build/linux/unbundle/ffmpeg.gn b/build/linux/unbundle/ffmpeg.gn
+--- a/build/linux/unbundle/ffmpeg.gn
++++ b/build/linux/unbundle/ffmpeg.gn
+@@ -12,6 +12,7 @@ pkg_config("system_ffmpeg") {
+ "libavformat",
+ "libavutil",
+ ]
++ defines = [ "av_stream_get_first_dts(stream)=stream->first_dts" ]
+ }
+
+ buildflag_header("ffmpeg_features") {