summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:14:13 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:18 +0300
commit37fa904f0b00eae091750e8fdb92d5aec3013256 (patch)
treee914f826e973888b292d229c9dd7e673524f5345 /gnu
parent99092bd9002da40370af48beae5a8530276a792b (diff)
downloadguix-patches-37fa904f0b00eae091750e8fdb92d5aec3013256.tar
guix-patches-37fa904f0b00eae091750e8fdb92d5aec3013256.tar.gz
gnu: Add emacs-slime-company.
* gnu/packages/emacs.scm (emacs-slime-company): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d71ef1fde1..b294a1bd34 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10102,3 +10102,28 @@ Emacs minor mode to escape sequences in code.")
(description "This package provides an extensible Emacs dashboard, with
sections for bookmarks, projectil projects, org-agenda and more. ")
(license license:gpl3+)))
+
+(define-public emacs-slime-company
+ (package
+ (name "emacs-slime-company")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/anwyn/slime-company/archive/"
+ "v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1myl79pxj501xfr5qc5a24qddsn2l5iaamg7rf7fpny7mr9v70ar"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-slime" ,emacs-slime)
+ ("emacs-company" ,emacs-company)))
+ (home-page "https://company-mode.github.io")
+ (synopsis "SLIME completion backend for @code{company-mode}")
+ (description
+ "This is a backend implementation for the completion package
+@code{company-mode} which supports the normal and the fuzzy completion
+modes of SLIME.")
+ (license license:gpl3+)))