summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-08 17:32:50 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-09 11:58:50 +0200
commit3125255cc5a51a0ac435408c73ed6253070ea215 (patch)
tree7829216f92630c86c1158233327d7de60f27ff91 /gnu
parentc7cfe540181f823e20c8b8b4e23b193dcb319856 (diff)
downloadguix-patches-3125255cc5a51a0ac435408c73ed6253070ea215.tar
guix-patches-3125255cc5a51a0ac435408c73ed6253070ea215.tar.gz
gnu: python-seaborn: Simplify 'start-xserver' phase.
* gnu/packages/python-xyz.scm (python-seaborn)[arguments]: In 'start-xserver' phase, assume "Xvfb" is in $PATH.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 193c86ac48..7a522853ff 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8812,13 +8812,11 @@ SVG, EPS, PNG and terminal output.")
`(#:phases
(modify-phases %standard-phases
(add-before 'check 'start-xserver
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xorg-server (assoc-ref inputs "xorg-server")))
- ;; There must be a running X server and make check doesn't
- ;; start one. Therefore we must do it.
- (system (format #f "~a/bin/Xvfb :1 &" xorg-server))
- (setenv "DISPLAY" ":1")
- #t)))
+ (lambda _
+ ;; There must be a running X server and make check doesn't
+ ;; start one. Therefore we must do it.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?