summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-06-15 03:33:42 +0200
committerCyril Roelandt <tipecaml@gmail.com>2013-06-17 19:33:53 +0200
commitcf3fe3b0710bf538c747068d6337db70522ce75d (patch)
tree03ac85c476ca7e4ea98a48e66239163f28fa32c2 /gnu
parent5686807ee9b0352931c2d0394885f5b43d53bcf1 (diff)
downloadguix-patches-cf3fe3b0710bf538c747068d6337db70522ce75d.tar
guix-patches-cf3fe3b0710bf538c747068d6337db70522ce75d.tar.gz
gnu: Move subversion with the other version control systems.
* gnu/packages/subversion.scm: Remove file. * gnu/packages/version-control.scm (subversion): New variable. * Makefile.am (MODULES): remove subversion.scm.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/subversion.scm58
-rw-r--r--gnu/packages/version-control.scm36
2 files changed, 35 insertions, 59 deletions
diff --git a/gnu/packages/subversion.scm b/gnu/packages/subversion.scm
deleted file mode 100644
index 28ddc42e00..0000000000
--- a/gnu/packages/subversion.scm
+++ /dev/null
@@ -1,58 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages subversion)
- #:use-module ((guix licenses) #:select (asl2.0))
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages libapr)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages python)
- #:use-module (gnu packages sqlite))
-
-(define-public subversion
- (package
- (name "subversion")
- (version "1.7.8")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.apache.org/dist/subversion/subversion-"
- version ".tar.bz2"))
- (sha256
- (base32
- "11inl9n1riahfnbk1fax0dysm2swakzhzhpmm2zvga6fikcx90zw"))))
- (build-system gnu-build-system)
- (inputs
- `(("libapr" ,libapr)
- ("libaprutil" ,libaprutil)
- ("perl" ,perl)
- ("python" ,python)
- ("sqlite" ,sqlite)
- ("zlib" ,zlib)))
- (home-page "http://subversion.apache.org/")
- (synopsis "Subversion, a revision control system")
- (description
- "Subversion exists to be universally recognized and adopted as an
-open-source, centralized version control system characterized by its
-reliability as a safe haven for valuable data; the simplicity of its model and
-usage; and its ability to support the needs of a wide variety of users and
-projects, from individuals to large-scale enterprise operations.")
- (license asl2.0)))
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6654be93b2..018cf1b9f8 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -17,7 +18,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages version-control)
- #:use-module ((guix licenses) #:select (gpl1+ gpl2+ gpl3+))
+ #:use-module ((guix licenses) #:select (asl2.0 gpl1+ gpl2+ gpl3+))
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
@@ -25,7 +26,11 @@
#:use-module (guix build utils)
#:use-module ((gnu packages gettext)
#:renamer (symbol-prefix-proc 'guix:))
+ #:use-module (gnu packages libapr)
#:use-module (gnu packages nano)
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages sqlite)
#:use-module (gnu packages compression))
(define-public bazaar
@@ -56,6 +61,35 @@ organize their workspace in whichever way they want. It is possible to work
from a command line or use a GUI application.")
(license gpl2+)))
+(define-public subversion
+ (package
+ (name "subversion")
+ (version "1.7.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.apache.org/dist/subversion/subversion-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "11inl9n1riahfnbk1fax0dysm2swakzhzhpmm2zvga6fikcx90zw"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libapr" ,libapr)
+ ("libaprutil" ,libaprutil)
+ ("perl" ,perl)
+ ("python" ,python)
+ ("sqlite" ,sqlite)
+ ("zlib" ,zlib)))
+ (home-page "http://subversion.apache.org/")
+ (synopsis "Subversion, a revision control system")
+ (description
+ "Subversion exists to be universally recognized and adopted as an
+open-source, centralized version control system characterized by its
+reliability as a safe haven for valuable data; the simplicity of its model and
+usage; and its ability to support the needs of a wide variety of users and
+projects, from individuals to large-scale enterprise operations.")
+ (license asl2.0)))
+
(define-public rcs
(package
(name "rcs")