summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-12-29 12:36:01 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-17 20:43:51 +0200
commit81c29cccaad8760fec6f3673a80648e942b79f8b (patch)
tree7741be110325c054716f8d7fc591a538aa07f0b5 /gnu
parent3161d32d37e84ad686c249cfb077126a1c9510c6 (diff)
downloadguix-patches-81c29cccaad8760fec6f3673a80648e942b79f8b.tar
guix-patches-81c29cccaad8760fec6f3673a80648e942b79f8b.tar.gz
gnu: mpv: Add features.
* gnu/packages/video.scm (mpv)[inputs]: Add libvdpau. [arguments]: Add gpl3 and zsh completion flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 82f62a4077..6fd2300f0a 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -707,7 +707,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
`(("perl" ,perl)
("pkg-config" ,pkg-config)
("python-docutils" ,python-docutils)))
- ;; Missing features: libguess, Wayland, VDPAU, V4L2
+ ;; Missing features: libguess, Wayland, V4L2
(inputs
`(("alsa-lib" ,alsa-lib)
("enca" ,enca)
@@ -724,6 +724,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
("libdvdnav" ,libdvdnav)
("libjpeg" ,libjpeg)
("libva" ,libva)
+ ("libvdpau" ,libvdpau)
("libx11" ,libx11)
("libxext" ,libxext)
("libxinerama" ,libxinerama)
@@ -754,6 +755,7 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(lambda* (#:key inputs #:allow-other-keys)
(copy-file (assoc-ref inputs "waf") "waf")
(setenv "CC" "gcc"))))
+ #:configure-flags (list "--enable-gpl3" "--enable-zsh-comp")
;; No check function defined.
#:tests? #f))
(home-page "http://mpv.io/")