summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-01-13 09:21:56 +0800
committer宋文武 <iyzsong@gmail.com>2016-01-16 08:16:51 +0800
commit2216e15cc310a52026adb3542897b4221c793d55 (patch)
tree0d20afd299644eb910ae824b759af5354592831e /gnu
parent78e6c4a86289bba0406facc3548a3992a58ba52f (diff)
downloadguix-patches-2216e15cc310a52026adb3542897b4221c793d55.tar
guix-patches-2216e15cc310a52026adb3542897b4221c793d55.tar.gz
gnu: Add python-args.
* gnu/packages.scm (python-args, python2-args): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c3e9f42ec1..40f086432f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6962,3 +6962,25 @@ files for use with Python.")
Blog, News or Announcements section to a Sphinx website.")
(home-page "https://bitbucket.org/prometheus/sphinxcontrib-newsfeed")
(license bsd-2)))
+
+(define-public python-args
+ (package
+ (name "python-args")
+ (version "0.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "args" version))
+ (sha256
+ (base32
+ "057qzi46h5dmxdqknsbrssn78lmqjlnm624iqdhrnpk26zcbi1d7"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)))
+ (home-page "https://github.com/kennethreitz/args")
+ (synopsis "Command-line argument parser")
+ (description
+ "This library provides a Python module to parse command-line arguments.")
+ (license bsd-3)))
+
+(define-public python2-args
+ (package-with-python2 python-args))