summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 04:49:55 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 16:06:10 +0100
commitfc783fb264011a2f92b53fac272f9fb21ebf970a (patch)
tree5979c70959c3d57b6f0e8dcfd2f6bc99de150d8f /gnu
parente0f71c802c8e15257cd5d279c6419557806a5d0f (diff)
downloadguix-patches-fc783fb264011a2f92b53fac272f9fb21ebf970a.tar
guix-patches-fc783fb264011a2f92b53fac272f9fb21ebf970a.tar.gz
gnu: indent: Update phase style.
* gnu/packages/indent.scm (indent)[arguments]: Use MODIFY-PHASES syntax and end phase with #t.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/indent.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/indent.scm b/gnu/packages/indent.scm
index 4950a26121..3465d63c01 100644
--- a/gnu/packages/indent.scm
+++ b/gnu/packages/indent.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,15 +37,16 @@
"0f9655vqdvfwbxvs1gpa7py8k1z71aqh8hp73f65vazwbfz436wa"))))
(build-system gnu-build-system)
(arguments
- `(#:phases (alist-cons-after
- 'unpack 'fix-docdir
- (lambda _
- ;; Although indent uses a modern autoconf in which docdir
- ;; defaults to PREFIX/share/doc, the doc/Makefile.am
- ;; overrides this to be in PREFIX/doc. Fix this.
- (substitute* "doc/Makefile.in"
- (("^docdir = .*$") "docdir = @docdir@\n")))
- %standard-phases)))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-docdir
+ (lambda _
+ ;; Although indent uses a modern autoconf in which docdir
+ ;; defaults to PREFIX/share/doc, the doc/Makefile.am
+ ;; overrides this to be in PREFIX/doc. Fix this.
+ (substitute* "doc/Makefile.in"
+ (("^docdir = .*$") "docdir = @docdir@\n"))
+ #t)))))
(synopsis "Code reformatter")
(description
"Indent is a program that makes source code easier to read by