summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-05-08 11:24:19 +0300
committerAlex Kost <alezost@gmail.com>2016-05-16 18:01:18 +0300
commit99404fff9f8be0478191dfd5a4ebbb5822527172 (patch)
tree90e64b3f3a49828b02c16965549d88b667ba2d6e /gnu
parent7d0c3c8d018a4aff4ce42f863ce81242555ab119 (diff)
downloadguix-patches-99404fff9f8be0478191dfd5a4ebbb5822527172.tar
guix-patches-99404fff9f8be0478191dfd5a4ebbb5822527172.tar.gz
gnu: mu: Use 'modify-phases'.
* gnu/packages/mail.scm (mu): Use 'modify-phases'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index b127419d7b..a2af7c7f97 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
+;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -364,18 +365,18 @@ repository and Maildir/IMAP as LOCAL repository.")
("gmime" ,gmime)
("tzdata" ,tzdata))) ;for mu/test/test-mu-query.c
(arguments
- '(#:phases (alist-cons-after
- 'unpack 'autoreconf
- (lambda _
- (zero? (system* "autoreconf" "-vi")))
- (alist-cons-before
- 'check 'check-tz-setup
- (lambda* (#:key inputs #:allow-other-keys)
- ;; For mu/test/test-mu-query.c
- (setenv "TZDIR"
- (string-append (assoc-ref inputs "tzdata")
- "/share/zoneinfo")))
- %standard-phases))))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autoreconf
+ (lambda _
+ (zero? (system* "autoreconf" "-vi"))))
+ (add-before 'check 'check-tz-setup
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; For mu/test/test-mu-query.c
+ (setenv "TZDIR"
+ (string-append (assoc-ref inputs "tzdata")
+ "/share/zoneinfo"))
+ #t)))))
(home-page "http://www.djcbsoftware.nl/code/mu/")
(synopsis "Quickly find emails")
(description