summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-09-03 10:54:18 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-09-04 14:53:36 +0200
commitddb8852a9beab231e2bbf4e51f8f62a644ff6ad0 (patch)
tree14081726caf428b200dbb9c8f0ff7d021006253d /gnu
parent466ccb9b7a91f8ef547dd6b6f46997be39b9357e (diff)
downloadguix-patches-ddb8852a9beab231e2bbf4e51f8f62a644ff6ad0.tar
guix-patches-ddb8852a9beab231e2bbf4e51f8f62a644ff6ad0.tar.gz
gnu: python-munkres: Update to 1.1.4.
* gnu/packages/python-xyz.scm (python-munkres) [version]: Update to 1.1.4. [arguments]: Re-enable test suite. [native-inputs]: Add pytest.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 12adafa892..3bb75bdadc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13670,16 +13670,15 @@ way.")
(define-public python-munkres
(package
(name "python-munkres")
- (version "1.0.8")
+ (version "1.1.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "munkres" version))
(sha256
(base32
- "0mbspx4zv8id4x6pim6ybsa1xh96qwpbqj7skbqz4c9c9nf1lpqq"))))
+ "00yvj8bxmhhhhd74v7j0x673is7vizmxwgb3dd5xmnkr74ybyi7w"))))
(build-system python-build-system)
- (arguments
- '(#:tests? #f)) ; no test suite
+ (native-inputs `(("python-pytest" ,python-pytest-6)))
(home-page "https://software.clapper.org/munkres/")
(synopsis "Implementation of the Munkres algorithm")
(description "The Munkres module provides an implementation of the Munkres