summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-10 14:24:34 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-10 14:24:34 +0200
commitd4c04e509bb58e34ae14f76f05c54f1d7c1334d5 (patch)
tree855b6a7fae117b305a0cad7c0c763f1e116306c1 /gnu
parente5eef324459291a7d48661e5d80954d6160f2a55 (diff)
downloadguix-patches-d4c04e509bb58e34ae14f76f05c54f1d7c1334d5.tar
guix-patches-d4c04e509bb58e34ae14f76f05c54f1d7c1334d5.tar.gz
gnu: Remove python-contextlib2.
This package is part of the Python standard library since version 3.2. * gnu/packages/python.scm (python-contextlib2): Rename to ... (python2-contextlib2): ... this. Remove previous incarnation. [arguments]: Set #:python.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a057e2a6a3..344de73603 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7159,9 +7159,9 @@ be set via config files and/or environment variables.")
@code{ArgumentParser} object.")
(license license:asl2.0)))
-(define-public python-contextlib2
+(define-public python2-contextlib2
(package
- (name "python-contextlib2")
+ (name "python2-contextlib2")
(version "0.4.0")
(source
(origin
@@ -7172,7 +7172,8 @@ be set via config files and/or environment variables.")
"0cmp131dlh0d0zvw0aza1zd13glvngzk8lb4avks0hm7yxwdr9am"))))
(build-system python-build-system)
(arguments
- `(#:phases
+ `(#:python ,python-2
+ #:phases
(modify-phases %standard-phases
(replace 'check
(lambda _ (zero?
@@ -7187,9 +7188,6 @@ managers. It also contains additional features that are not part of
the standard library.")
(license license:psfl)))
-(define-public python2-contextlib2
- (package-with-python2 python-contextlib2))
-
(define-public python-texttable
(package
(name "python-texttable")