summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-01 21:20:45 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-01 21:27:35 +0200
commitaa4d18f33cb382f094b98bd2cb7ff911b2f72388 (patch)
tree94801ff5b80f618387989550f0aa8cf0e7b6e018 /gnu
parent0d38f821202f0cf88248684d1e1c63d3f8f868fe (diff)
downloadguix-patches-aa4d18f33cb382f094b98bd2cb7ff911b2f72388.tar
guix-patches-aa4d18f33cb382f094b98bd2cb7ff911b2f72388.tar.gz
gnu: rtl8821ce-linux-module: Honour PARALLEL-BUILD?.
* gnu/packages/linux.scm (rtl8821ce-linux-module)[arguments]: Spawn multiple build make jobs if requested.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 31ba243d23..3cefa2f644 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1401,8 +1401,13 @@ RTL8812AU, RTL8821AU, and RTL8814AU chips.")
#:phases
(modify-phases %standard-phases
(replace 'build
- (lambda* (#:key (make-flags '()) #:allow-other-keys)
- (apply invoke "make" make-flags))))
+ (lambda* (#:key (make-flags '()) (parallel-build? #t)
+ #:allow-other-keys)
+ (apply invoke "make"
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags)))))
#:tests? #f)) ; no test suite
(home-page "https://github.com/tomaspinho/rtl8821ce")
(synopsis "Linux driver for Realtek RTL8821CE wireless network adapters")