summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-11 01:30:09 +0100
committerMarius Bakke <marius@gnu.org>2022-01-11 18:36:39 +0100
commit96c214f50532e3978440ea7e35bd9c0fe4f654cc (patch)
treec228f2a2db4b86d121261cb08bd4be41dc739d2a /gnu
parent5d9dbe081989b681216f1507da8af834bfb23941 (diff)
downloadguix-patches-96c214f50532e3978440ea7e35bd9c0fe4f654cc.tar
guix-patches-96c214f50532e3978440ea7e35bd9c0fe4f654cc.tar.gz
gnu: python-imagecodecs: Disable sanity check.
* gnu/packages/python-xyz.scm (python-imagecodecs)[arguments]: Disable sanity-check phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b544444db1..36434a4707 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7166,8 +7166,10 @@ def customize_build(EXTENSIONS, OPTIONS):
del EXTENSIONS['zfp']
del EXTENSIONS['zopfli']
OPTIONS['cythonize']
-")))
- #t)))))
+")))))
+ ;; XXX: The installed scripts import packages that depend on
+ ;; this package; disable import check to avoid the cycle.
+ (delete 'sanity-check))))
(inputs
(list c-blosc
giflib
@@ -7182,6 +7184,7 @@ def customize_build(EXTENSIONS, OPTIONS):
zlib
`(,zstd "lib")))
(propagated-inputs
+ ;; For the Python library.
(list python-numpy))
(native-inputs
;; For building.