summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-19 15:42:32 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-20 22:47:03 -0500
commit95a69453f4ce7144def26afa62ea596cde0e4093 (patch)
treef68de8527f0b158d6418128830a3caee88f66cf7 /gnu
parent575902e9038c9265ea880d70222025af243fab21 (diff)
downloadguix-patches-95a69453f4ce7144def26afa62ea596cde0e4093.tar
guix-patches-95a69453f4ce7144def26afa62ea596cde0e4093.tar.gz
gnu: python2-gdrivefs: Remove package.
* gnu/packages/python-xyz.scm (python2-gdrivefs): Remove variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm41
1 files changed, 0 insertions, 41 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 618cf9294d..633f153f68 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18701,47 +18701,6 @@ interface to FUSE on various operating systems. It's just one file and is
implemented using @code{ctypes}.")
(license license:isc)))
-(define-public python2-gdrivefs
- (package
- (name "python2-gdrivefs")
- (version "0.14.9")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "gdrivefs" version))
- (sha256
- (base32
- "0v9sp2cfg4ki3wagkwf3rnfpjhvgf845anz3757il9z95yvvcvb7"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'patch-setup-py
- (lambda _
- ;; Update requirements from dependency==version
- ;; to dependency>=version
- (substitute* "gdrivefs/resources/requirements.txt"
- (("==") ">="))
- #t)))))
- (native-inputs
- `(("python2-gipc" ,python2-gipc)
- ("python2-gevent" ,python2-gevent)
- ("python2-greenlet" ,python2-greenlet)
- ("python2-httplib2" ,python2-httplib2)
- ("python2-uritemplate" ,python2-uritemplate)
- ("python2-oauth2client" ,python2-oauth2client)
- ("python2-six" ,python2-six)))
- (propagated-inputs
- `(("python2-dateutil" ,python2-dateutil)
- ("python2-fusepy" ,python2-fusepy)
- ("python2-google-api-client" ,python2-google-api-client)))
- (home-page "https://github.com/dsoprea/GDriveFS")
- (synopsis "Mount Google Drive as a local file system")
- (description "@code{gdrivefs} provides a FUSE wrapper for Google Drive
-under Python 2.7.")
- (license license:gpl2)))
-
(define-public python-userspacefs
(package
(name "python-userspacefs")