summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-09-02 20:11:05 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-09-04 14:53:35 +0200
commit8330b0cfbbe676ce32acabb2f852d23a5ba483f5 (patch)
treedf319d795d855db9e78fed987c4e4e020ec591f0 /gnu
parent46ba1bb068492192ba69d52c00ca8224956a3849 (diff)
downloadguix-patches-8330b0cfbbe676ce32acabb2f852d23a5ba483f5.tar
guix-patches-8330b0cfbbe676ce32acabb2f852d23a5ba483f5.tar.gz
gnu: python-pylast: Update to 4.2.1.
* gnu/packages/music.scm (python-pylast) [version]: Update to 4.2.1. [propagated-inputs]: Move… [native-inputs]: …here and remove unneccessary inputs. (python2-pylast): Remove, since Python 2 is not supported by upstream any more.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 0a1a311511..944aa74bad 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3711,37 +3711,29 @@ detailed track info including timbre, pitch, rhythm and loudness information.
(define-public python-pylast
(package
(name "python-pylast")
- (version "2.0.0")
+ (version "4.2.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "pylast" version))
(sha256
(base32
- "0r9h7g8i8l2mgqjwkda3v6prfbkb2im5kap1az9ppmhjm9i4jkcf"))))
+ "0pzzhr4mlwpvfhy9gzq86ppz29fmf5z0w3xkl5if1fm59r1afms7"))))
(build-system python-build-system)
;; Tests require network access. See
;; https://github.com/pylast/pylast/issues/105
(arguments '(#:tests? #f))
(native-inputs
`(("python-coverage" ,python-coverage)
- ("python-pycodestyle" ,python-pycodestyle)
- ("python-mock" ,python-mock)
- ("python-pep8" ,python-pep8)
("python-pytest" ,python-pytest)
("python-flaky" ,python-flaky)
- ("python-pyflakes" ,python-pyflakes)
- ("python-pyyaml" ,python-pyyaml)))
- (propagated-inputs
- `(("python-six" ,python-six)))
+ ("python-pyyaml" ,python-pyyaml)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
(home-page "https://github.com/pylast/pylast")
(synopsis "Python interface to Last.fm and Libre.fm")
(description "A Python interface to Last.fm and other API-compatible
websites such as Libre.fm.")
(license license:asl2.0)))
-(define-public python2-pylast
- (package-with-python2 python-pylast))
-
(define-public instantmusic
(let ((commit "300891d09c703525215fa5a116b9294af1c923c8")
(revision "1"))